The RACING Gabi (Gabelstapler)

Mindstorms im Unterricht. Ideen, Vorstellungen

Moderator: Moderatoren

Benutzeravatar
Dunkle Macht
Enorm-Viel-Schreiber
Enorm-Viel-Schreiber
Beiträge: 749
Registriert: 6. Jun 2008 15:37
Wohnort: Legau
Kontaktdaten:

Beitragvon Dunkle Macht » 1. Mär 2009 10:08

Ja...

Ich hab ja icht gesagt dass es "unmöglich" ist :? . Aber ich finde das mit der schnur besser.

Benutzeravatar
WvBRobotikTeam5
Weniger als 15 Beiträge
Weniger als 15 Beiträge
Beiträge: 16
Registriert: 19. Feb 2009 10:05

Beitragvon WvBRobotikTeam5 » 2. Mär 2009 22:18

Ich bin begeistert....

Danke dass ihr uns so gut helft.

Benutzeravatar
WvBRobotikTeam5
Weniger als 15 Beiträge
Weniger als 15 Beiträge
Beiträge: 16
Registriert: 19. Feb 2009 10:05

Beitragvon WvBRobotikTeam5 » 8. Mär 2009 15:17

Wir haben uns jetzt für die Idee mit dem Faden entschieden. Der Roboter ist auch bereits fertig konstruiert und funktoniert.
Wir haben, dass die Gabel besser und einfach hoch und runter fahren kann, eine Laufschiene angebraucht, in der sie hoch und runter fährt. Am Ende dieser Laufschiene haben wir einen TouchSensor angebracht, den wir programmieren können. Immer wenn die Gabel nach oben fährt. berührt sie in Nähe des oberen Totpunkts den TouchSensor und so können wir dann programmieren, dass er dann die Motoren ausschalten soll, sodass der Motor nicht den Faden überdreht und reisst. (Haben wir auch schon hinbekommen =) )

In kürze werden wir auch ein Bild hochstellen, wo ihr unsern ultra-mega-coolen Roboter betrachten könnt. Alles Eigenproduktion. Keine Anleitungen wurden miteinbezogen. Alles alleine durch die hellen Köpfe des Bauteams.

Benutzeravatar
Dunkle Macht
Enorm-Viel-Schreiber
Enorm-Viel-Schreiber
Beiträge: 749
Registriert: 6. Jun 2008 15:37
Wohnort: Legau
Kontaktdaten:

Beitragvon Dunkle Macht » 9. Mär 2009 14:08

Da bin ich ja mal gespannt.

Wie sieht es denn mit dem Rest vom Programm aus?

Benutzeravatar
WvBRobotikTeam5
Weniger als 15 Beiträge
Weniger als 15 Beiträge
Beiträge: 16
Registriert: 19. Feb 2009 10:05

Beitragvon WvBRobotikTeam5 » 10. Mär 2009 11:00

Ein Problem ist aufgekommen. Aufgrund der Bauweise ist es uns kaum möglich 2 Lichtsensoren anzubauen um an der Linie langzufahren. Wir werden heute Mittag ein Bild hochstellen, das uns Problem etwas genauer darstellt. Wir hoffen das ihr uns einen Tipp geben könnt und vielleicht Ideen habt doch noch den 3ten Lichtsensor anzuschließen und auch zu benutzen.

Liebe Grüße
Robotikteam5

Benutzeravatar
WvBRobotikTeam5
Weniger als 15 Beiträge
Weniger als 15 Beiträge
Beiträge: 16
Registriert: 19. Feb 2009 10:05

Beitragvon WvBRobotikTeam5 » 17. Mär 2009 09:40

Auf diesem Link könnt ihr das Bild von unserem Roboter downloaden...

www.uploaded.to/?id=e8opgi

www.uploaded.to/?id=9xa8u5


Viel Spaß... Wir hoffe auf weitere Anregungen =)

Benutzeravatar
Ciclon
Hilft fleißig mit!!!
Hilft fleißig mit!!!
Beiträge: 64
Registriert: 23. Dez 2008 14:01

Beitragvon Ciclon » 17. Mär 2009 13:07

könnt ihr bilder nicht einfach hier http://img1.imageshack.us/ hochladen..da muss ma nicht warten und bekommt das bild sofort

Benutzeravatar
WvBRobotikTeam5
Weniger als 15 Beiträge
Weniger als 15 Beiträge
Beiträge: 16
Registriert: 19. Feb 2009 10:05

Beitragvon WvBRobotikTeam5 » 19. Mär 2009 09:54


Benutzeravatar
Dunkle Macht
Enorm-Viel-Schreiber
Enorm-Viel-Schreiber
Beiträge: 749
Registriert: 6. Jun 2008 15:37
Wohnort: Legau
Kontaktdaten:

Beitragvon Dunkle Macht » 19. Mär 2009 16:31

Ja.
Der sieht nicht schlecht aus.
Was macht das Programm?

Benutzeravatar
sirs
Schreibt viel
Schreibt viel
Beiträge: 274
Registriert: 17. Mär 2008 16:45
Wohnort: Bayern!

Beitragvon sirs » 19. Mär 2009 17:34

probiert doch mal mit einem LS an einer Linie entlang zu fahren: Immer wenn die Farbe des Untergrunds wechselt, den einen Motor langsamer drehen lassen

Trotzdem gut! Kompakter Roboter! leider zu kompakt um unten drunter einen LS zu installieren. Vll unter den NXT dranbauen oder den NXT anders hinbasteln
Es grüßt euch sirs! hier klicken :)
Das KÄSEPARADOX: Je mehr Käse, desto mehr Löcher. Je mehr Löcher, desto weniger Käse. -> Mehr = Weniger

Benutzeravatar
WvBRobotikTeam5
Weniger als 15 Beiträge
Weniger als 15 Beiträge
Beiträge: 16
Registriert: 19. Feb 2009 10:05

Beitragvon WvBRobotikTeam5 » 19. Mär 2009 18:14

Erstmal wieder "HI" an alle =)

@ Dunkle Macht
- bis jetzt haben wir uns nur darauf konzentriert, dass der Roboter
die Lastgabel hochbewegt, bis der Touch-Sensor gedrückt wird.
Jetzt sind wir momentan beschäftigt einen zweiten Touch-Sensor
am Roboter zu befestigen, der dann eingreift wenn die Lastgabel
ganz unten angekommen ist.

@ sirs
- Einen LS haben wir bereits am Boden des Roboters befestigt. Aber wir
sind bis jetzt noch nicht soweit um uns mit der Programmierung des
Lichtsensors zu beschäftigen. Den Lichtsensor den du siehst, ist der
zweite Lichtsensor, der den Helligkeitswert der Kugel erkennt und
dann entscheidet in welches Regal die Kugel gebracht werden soll.

Wir werden in unseren nächsten Informatik-Stunde nocheinmal ein Bild hochladen, auf dem ihr den Boden des Roboters erkennen könnt. Darauf könnt ihr dann auch den 1. Lichtsensor erkennen.

Über weitere Beiträge und Tipps freuen wir uns =) MfG WvBRobotikTeam5

Benutzeravatar
WvBRobotikTeam5
Weniger als 15 Beiträge
Weniger als 15 Beiträge
Beiträge: 16
Registriert: 19. Feb 2009 10:05

Beitragvon WvBRobotikTeam5 » 30. Apr 2009 08:32

Hallo,

Nachdem die Osterferien rum sind und unser Informatikunterricht wieder angefangen hat, haben wir uns endlich mal dran gesetzt die Fotos vom Roboter hochzuladen.

So zu unseren neusten Ergebnissen:

1. Roboter fertig konstruiert
2. Programm zur Fahrt auf einer Linie erstellt
3. Gabel anheben und senken funktioniert mit Hilfe der
Touch-Sensoren ebenfalls

Probleme:

1. Wie sollen wir den Roboter programmieren, sodass der Roboter
anhand der Farbe der Kugel erkennt, ob er links oder rechtsrum
fahren soll ?

Bilder befinden sich hier :


Roboter :

http://img242.imageshack.us/my.php?image=dsc00603w.jpg
http://img527.imageshack.us/my.php?image=dsc00600m.jpg
http://img99.imageshack.us/my.php?image=dsc00601bjo.jpg
http://img90.imageshack.us/my.php?image=dsc00602l.jpg

Strecke (Problem) :

http://img504.imageshack.us/my.php?image=dsc00604w.jpg

Wir bitten um zahlreiche Helfer, bzw. Kommis.
Danke =)

Benutzeravatar
WvBRobotikTeam5
Weniger als 15 Beiträge
Weniger als 15 Beiträge
Beiträge: 16
Registriert: 19. Feb 2009 10:05

Beitragvon WvBRobotikTeam5 » 30. Apr 2009 08:32

Wir hoffen man kann die Bilder gut erkennen =)

Benutzeravatar
Dunkle Macht
Enorm-Viel-Schreiber
Enorm-Viel-Schreiber
Beiträge: 749
Registriert: 6. Jun 2008 15:37
Wohnort: Legau
Kontaktdaten:

Beitragvon Dunkle Macht » 30. Apr 2009 15:01

Ja.Das sieht doch ganz gut aus.

Wie siehts mit der programmierung denn aus?

Benutzeravatar
WvBRobotikTeam5
Weniger als 15 Beiträge
Weniger als 15 Beiträge
Beiträge: 16
Registriert: 19. Feb 2009 10:05

Beitragvon WvBRobotikTeam5 » 5. Mai 2009 09:35

Dunkle Macht hat geschrieben:Ja.Das sieht doch ganz gut aus.

Wie siehts mit der programmierung denn aus?


Ja gut.. ähm. Wir haben den Roboter soweit programmiert, dass er mit Hilfe des unteren Lichtsensors an einer vorgegebenen schwarzen Linie entlang fahren kann und somit die vorher plazierte Palette erfassen kann.

Außerdem kann er mit Hilfe der beiden Touch-Sensoren die Palette anheben bis TS 1 gedrückt ist und anschließend die Palette wieder absenken bis TS 2 gedrückt ist.

Unser Problem besteht darin, dass wir nicht wissen, wie wir den Roboter programmieren sollen, dass er an der Kreuzung, an der er entweder rechts(rote Kugel) oder links(blaue Kugel) fahren soll. Den Lichtwert der jeweiligen Kugel können wir bereits bestimmen, wir wissen jedoch nicht wie wir dann bestimmen sollen, wie er nach rechts oder nach links fahren soll.

Uns fehlt der Befehl ! :(

Bitte helft uns... wenn nicht auch per PN :D

MfG WvBRobotikTeam5


Zurück zu „Unterricht & AG“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 6 Gäste

Lego Mindstorms EV3, NXT und RCX Forum : Haftungsauschluss