Lego NXT Farbsensor

grafische Programmiersprachen für den EV3/NXT.
NXT-G, Robolab, LabView und was noch so schön bunt ist...

Moderator: Moderatoren

Dennis
Neuer Schreiber
Neuer Schreiber
Beiträge: 2
Registriert: 30. Jan 2016 14:04

Lego NXT Farbsensor

Beitragvon Dennis » 1. Feb 2016 13:29

Hallo,
zum Einstieg kurz vorgestellt: mein Name ist Thorsten aus 26135 Oldenburg
Ich bin Neuling im Forum und auch beim Thema Mindstorms.
Mein Junior hat zu Weihnachten ein Mindstorm-Set NXT 2.0 bekommen. So weit so gut - doch schon beim Nachbau des ersten Gefährts mit Nutzung des Farbsensors stoßen wir auf Probleme. Belegung und Einstellungen sind genau nach Lego-Vorgabe. Das Gefährt startet, jedoch blinken bei dem Sensor nur alle drei Dioden. Farben werden nicht erkannt.
Was ist die Ursache?

Danke & Gruss

Thorsten

Benutzeravatar
HaWe
Administrator
Administrator
Beiträge: 5402
Registriert: 11. Jan 2006 21:01
Wohnort: ein kleiner Planet in der Nähe von Beteigeuze

Re: Lego NXT Farbsensor

Beitragvon HaWe » 1. Feb 2016 14:48

Hallo, erst mal herzlich willkommen!
Nachdem der NXT-Kasten samt zugehörigem Programm schon mindestens 6 Jahre in dieser Form bestehen dürfte und bisher noch niemand einen derartigen Fehler berichtet hat, ist sicher deine Aussage
Belegung und Einstellungen sind genau nach Lego-Vorgabe

mit einer gewissen Portion Skepsis zu bewerten - guck nochmal genau, ich bin sicher, du findest da euren Fehler.
Gruß,
HaWe
±·≠≈²³αβγδε∂ζλμνπξφωΔΦ≡ΠΣΨΩ∫√∀∃∈∉∧∨¬⊂⊄∩∪∅∞®
NXT NXC SCHACHROBOTER: https://www.youtube.com/watch?v=Cv-yzuebC7E

gjb
Weniger als 15 Beiträge
Weniger als 15 Beiträge
Beiträge: 19
Registriert: 10. Sep 2013 18:04

Re: Lego NXT Farbsensor

Beitragvon gjb » 2. Feb 2016 18:19

Dennis hat geschrieben:Mein Junior hat zu Weihnachten ein Mindstorm-Set NXT 2.0 bekommen. So weit so gut - doch schon beim Nachbau des ersten Gefährts mit Nutzung des Farbsensors stoßen wir auf Probleme. Belegung und Einstellungen sind genau nach Lego-Vorgabe. Das Gefährt startet, jedoch blinken bei dem Sensor nur alle drei Dioden. Farben werden nicht erkannt.


Hallo Dennis,
die erste Fragen, die ich im Rahmen der Ferndiagnose stellen würde:
- ist der Farbsensor wirklich der NXT-Sensor (oder HiTechnic oder gar EV3)
Edit: Der EV3 hat nicht drei LEDs uns scheidet damit aus
- habt ihr die Kabel geprüft bzw. durchgetauscht?
- was sagt der View-Modus: http://www.ortop.org/NXT_Tutorial/Viewing_Sensors.html
- welche Firmware-Version hat der NXT-Stein? Der Farbsensor kam ja später, ältere NXT-Steine muss man m W. updaten, damit sie mit dem Farbsensor "können"

Beste Grüße Gerhard
Beste Grüße Gerhard
expermentiere mit NXT | EV3 | mBlock | Arduino

Dennis
Neuer Schreiber
Neuer Schreiber
Beiträge: 2
Registriert: 30. Jan 2016 14:04

Re: Lego NXT Farbsensor

Beitragvon Dennis » 7. Feb 2016 16:56

Hallo,
danke für die schnellen Rückmeldungen. Wir sind die einzelnen Tipps nochmal durchgegangen, leider ohne Erfolg.
- Farbsensor ist der Lego 9694
- Kabels sind durchgetauscht, auch an verschiedenen Ports
- Firmware 1.31
- Im View Modus, direkt am Next-Stein nur Blinken der LEDs keine Erkennung. Anzeige "????????"

Benutzeravatar
HaWe
Administrator
Administrator
Beiträge: 5402
Registriert: 11. Jan 2006 21:01
Wohnort: ein kleiner Planet in der Nähe von Beteigeuze

Re: Lego NXT Farbsensor

Beitragvon HaWe » 7. Feb 2016 17:19

dann ist wohl entweder der Sensor oder der betr. NXT Port oder der ganze NXT kaputt - oder das Kabel.
Also erst mal Kabel tauschen.

Dann schreib mal ein einfaches Programm nur für den Sensor (Farbe erkennen und auf Bildschirm ausgeben), und zwar für alle 4 ports nacheinander, und dann die Ports damit durchtesten.
Gruß,
HaWe
±·≠≈²³αβγδε∂ζλμνπξφωΔΦ≡ΠΣΨΩ∫√∀∃∈∉∧∨¬⊂⊄∩∪∅∞®
NXT NXC SCHACHROBOTER: https://www.youtube.com/watch?v=Cv-yzuebC7E


Zurück zu „grafische Programmiersoftware“

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 8 Gäste

Lego Mindstorms EV3, NXT und RCX Forum : Haftungsauschluss