Problem: Ultraschallsensor SRF05 von Devantech am NXT ?

Atmel, PIC, VEX, Fischertechnik

Moderator: Moderatoren

noob405
Schreibt ab und zu
Schreibt ab und zu
Beiträge: 39
Registriert: 23. Aug 2011 19:44

Re: Problem: Ultraschallsensor SRF05 von Devantech am NXT ?

Beitragvon noob405 » 6. Sep 2011 07:13

Danke für die Antwort noch vorm Frühstück.
Ich werde heute Abend sicherheitshalber nochmal
meine Schaltung posten.
Nur um sicher zu gehen, dass ich später beim
Löten nicht die Feuerwehr am Hals habe.... ;-)

Benutzeravatar
NXT pro
Super-Enorm-Viel-Schreiber
Super-Enorm-Viel-Schreiber
Beiträge: 930
Registriert: 27. Sep 2010 21:38

Re: Problem: Ultraschallsensor SRF05 von Devantech am NXT ?

Beitragvon NXT pro » 6. Sep 2011 09:59

Beim Löten noch nicht, erst beim an-den-NXT-anschliessen :D
Real coders don't comment their code - it was hard to write, it should be hard to understand!

noob405
Schreibt ab und zu
Schreibt ab und zu
Beiträge: 39
Registriert: 23. Aug 2011 19:44

Re: Problem: Ultraschallsensor SRF05 von Devantech am NXT ?

Beitragvon noob405 » 6. Sep 2011 11:24

Jaja,
dann macht´s "Puff" und alle Kühe fallen um.....
Genau so stelle ich mir das vor :lol:

noob405
Schreibt ab und zu
Schreibt ab und zu
Beiträge: 39
Registriert: 23. Aug 2011 19:44

Re: Problem: Ultraschallsensor SRF05 von Devantech am NXT ?

Beitragvon noob405 » 6. Sep 2011 23:21

Hi zusammen,

könnt ihr bitte noch einmal auf meine "Platine" gucken? Vielleicht habe ich jetzt ja alle Hinweise
richtig umgesetzt.

Bild

Vielleicht fehlt mir aber immer noch das "entscheidende Etwas"

Der noob

Benutzeravatar
Sebi
Administrator
Administrator
Beiträge: 1946
Registriert: 11. Jan 2008 14:28
Wohnort: Aub
Kontaktdaten:

Re: Problem: Ultraschallsensor SRF05 von Devantech am NXT ?

Beitragvon Sebi » 6. Sep 2011 23:25

Das sollte jetzt richtig sein. Die Pinbelegung der Sensoren selber ist bloß anders, aber ich Schätze mal, das ist Absicht.

noob405
Schreibt ab und zu
Schreibt ab und zu
Beiträge: 39
Registriert: 23. Aug 2011 19:44

Re: Problem: Ultraschallsensor SRF05 von Devantech am NXT ?

Beitragvon noob405 » 7. Sep 2011 23:23

o.k. Ich habe jetzt noch einmal mein "Platinen-Layout" angepasst, wobei jetzt die Sensoren-Steckeranschlüsse
jetzt bei der Reihenfolg der Pinbelegung der SRF10 entspricht. Je dachdem, von wo man guckt gibt es m.E: zwei
Layouts:

Bild


und


Bild

Kann das jemand von Euch noch einmal auf Fehler durchsuchen?
Im postiven Fall würde ich dann kurzfristig mit dem Bau beginnen..... ;-)

Benutzeravatar
Sebi
Administrator
Administrator
Beiträge: 1946
Registriert: 11. Jan 2008 14:28
Wohnort: Aub
Kontaktdaten:

Re: Problem: Ultraschallsensor SRF05 von Devantech am NXT ?

Beitragvon Sebi » 8. Sep 2011 18:54

Sieht richtig aus. Der Name "Noob" passt wohl doch nicht so ganz ;)

Benutzeravatar
NXT pro
Super-Enorm-Viel-Schreiber
Super-Enorm-Viel-Schreiber
Beiträge: 930
Registriert: 27. Sep 2010 21:38

Re: Problem: Ultraschallsensor SRF05 von Devantech am NXT ?

Beitragvon NXT pro » 8. Sep 2011 22:03

Da in deiner Schaltung ja für bis zu vier SRF10 Platz ist, musst du bei allen SRF10 eine unterschiedliche I2C-Adresse festlegen.
Wie das funktioniert kannst du der Anleitung entnehmen.
Real coders don't comment their code - it was hard to write, it should be hard to understand!

noob405
Schreibt ab und zu
Schreibt ab und zu
Beiträge: 39
Registriert: 23. Aug 2011 19:44

Re: Problem: Ultraschallsensor SRF05 von Devantech am NXT ?

Beitragvon noob405 » 8. Sep 2011 23:44

Danke für Euer Feedback, dann kann ich mich ja jetzt demnächst an´s Hardware-Bauen und Programmieren machen.
@Sebi: Noob steht dann manchmal nur für "nicht offensichtlich ober-blöd".....
Na warten wir´s mal ab. Bei den nächsten Schritten kann man noch genug Blödsinn anstellen..... ;-)

noob405
Schreibt ab und zu
Schreibt ab und zu
Beiträge: 39
Registriert: 23. Aug 2011 19:44

Re: Problem: Ultraschallsensor SRF05 von Devantech am NXT ?

Beitragvon noob405 » 21. Sep 2011 21:14

Hi zusammen,

ich wärme den Thread nochmal auf mit ´ner Softwarefrage.
Habe mich jetzt mal ein bischen in I2C und die NXC-Programmierung eingelesen. Scheint mir alles relativ komplex zu sein
mit dem Ansprechen und Auslesen der Sensorwerte. Hat jemand von Euch vielleicht ´ne Quelle in Netz für mich,
in der das ein wenig detaillierter beschrieben ist?

Vielen Dank im voraus.

Der Noob

p.s.: ich "forsche" momentan immer noch ohne Hardware, so daß trial-and-error-Programmierung noch´ne Weile ausfällt.

noob405
Schreibt ab und zu
Schreibt ab und zu
Beiträge: 39
Registriert: 23. Aug 2011 19:44

Re: Problem: Ultraschallsensor SRF05 von Devantech am NXT ?

Beitragvon noob405 » 10. Mär 2014 23:44

Liebe Forenmitglieder,

es ist eine Weile vergangen. Mittlerweile habe ich erfolgreich meine "I2C-Schaltung" gebaut, die für sechs SRF10 ausgelegt ist.
Mir ist es auch gelungen, eine NXC-Library zu schreiben, mit der man die Sensorwerte ausliest.
Klappt alles wunderbar mit 4 Sensoren dran. Vielen Dank nochmal für alle kreativen Tipps!!

Ich hab´ mir jetzt mal testweise zwei weitere Sensoren ausgeliehen. Schließt man nun den fünften Sensor an, dann liefern
alle Sensoren plötzlich keine Werte mehr. Ich nehme mal an, dass die NXT-interne Stromversorgung am Sensorport dann
nicht mehr mitmacht. Jeder Sensor hat einen Verbrauch von 15mA.

Kann mir jemand von Euch bestätigen, dass 75 mA oder mehr zu viel sind für die Sensorports? Konnte nirgends eine Doku finden.
Eigene Stromversorgung nötig?

Viele Grüße und vielen Dank
Noob 405

Benutzeravatar
HaWe
Administrator
Administrator
Beiträge: 5404
Registriert: 11. Jan 2006 21:01
Wohnort: ein kleiner Planet in der Nähe von Beteigeuze

Re: Problem: Ultraschallsensor SRF05 von Devantech am NXT ?

Beitragvon HaWe » 11. Mär 2014 12:41

welche Sensoren hast du genau drangehängt?
Gruß,
HaWe
±·≠≈²³αβγδε∂ζλμνπξφωΔΦ≡ΠΣΨΩ∫√∀∃∈∉∧∨¬⊂⊄∩∪∅∞®
NXT NXC SCHACHROBOTER: https://www.youtube.com/watch?v=Cv-yzuebC7E

noob405
Schreibt ab und zu
Schreibt ab und zu
Beiträge: 39
Registriert: 23. Aug 2011 19:44

Re: Problem: Ultraschallsensor SRF05 von Devantech am NXT ?

Beitragvon noob405 » 11. Mär 2014 19:22

Hi Hawe,

statt der ursprünglich geplanten SRF5 habe ich nun die wesentlich kleineren SRF10
angeschlossen.
http://www.robotikhardware.de/download/srf10doku.pdf


Viele Grüße Noob405

noob405
Schreibt ab und zu
Schreibt ab und zu
Beiträge: 39
Registriert: 23. Aug 2011 19:44

Re: Problem: Ultraschallsensor SRF05 von Devantech am NXT ?

Beitragvon noob405 » 12. Mär 2014 15:47

Müsste dann wohl in meiner Schaltung die Sensorlinie nur noch SDA und SCL mit dem Brick verbinden und
5V und GND an einen LIPO anschließen, oder?

noob405
Schreibt ab und zu
Schreibt ab und zu
Beiträge: 39
Registriert: 23. Aug 2011 19:44

Re: Problem: Ultraschallsensor SRF05 von Devantech am NXT ?

Beitragvon noob405 » 15. Mär 2014 18:35

Da bin ich meinem Usernahmen mal gerecht geworden. Ich mal "mutig" und habe die
Anschlüsse meiner Schaltung verändert.

Bild

Die Idee, 5V und GND von einem LIPO zu nehmen und nur SDA und SCL vom NXT zu nehmen,
wurde mir aber mit einem verschmortem Sensor quittert. Der Geruch war "nett".... :-(


Hat jemand ´ne Ahnung, wie ich es hinbekomme eine externe Spannungsquelle anzuschließen,
ohne dass ich die Sernsoren grille, und ich gleichzeitig mit dem NXT die Werte auslese?

Viele Grüße
noob


Zurück zu „allgemeine / Nicht-Lego-Robotik und Elektronik“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 7 Gäste

Lego Mindstorms EV3, NXT und RCX Forum : Haftungsauschluss