NXT 2.0 Sensoreingänge defekt

EV3, NXT, Tetrix, Wedo... NXT-kompatible Zweit/Drittanbieter...

Moderator: Moderatoren

Tweeky
Mindstormsfreund
Mindstormsfreund
Beiträge: 8
Registriert: 10. Dez 2017 22:20

NXT 2.0 Sensoreingänge defekt

Beitragvon Tweeky » 13. Dez 2017 12:28

Hallo erst mal an alle hier!
Ich habe schon ein bisschen gesucht hier im Forum, habe aber auf mein Problem keine wirkliche Antwort gefunden.
Ich, bzw. mein Sohn besitzt ein NXT 2.0 Set. Hat bisher wunderbar funktioniert. Lag dann aber ca. 2 Jahr im Schrank und wurde nicht benutzt. Jetzt wollte der Junior wieder damit anfangen und siehe da die Sensoren, sämtliche (auch die der Motoren) funktionieren nicht mehr. Einzig die relativ dummen Taster tun was sie sollen. Das heißt man kann eigentlich nicht mehr anständig programmieren und das Set nutzen. Die Motoren drehen aber übrigens, allerdings funktioniert die Drehzahlvorgabe nicht.
Jetzt habe ich schon sämtliche Unterlagen gesammelt, den Brick aufgemacht und auch schon angefangen zu messen. Leider habe ich kein Oszi und auch kein Funktionsgenerator. Daher habe ich bisher nur die Spannungsversorgungen durchgemessen. Die funktionieren auch soweit. Die, von mir vermutet defekten Elkos sind alle i.O. Zumindest äusserlich. Einen habe ich zum Test ausgelötet und gemessen. Und wie erwartet war dieser auch i.O.

Kann mir jemand weiterhelfen? Was kann es ausser der Spannungsversorgung noch sein?

Die Sensoren würde ich eigentlich ausschliessen, da alle gleichzeitig defekt sein müssten. Kabel habe ich auch ausgeschlossen (durchgemessen und ausgetauscht).

Evtl. könnte ich in der Firma mit einem Oszi messen, dazu müsste ich aber wissen wo und was genau.
Bei den Unterlagen bin ich mir auch nicht sicher, ob diese passen, da ich einige Messpunkte und Bauteile einfach nicht auf der Platine finden kann (Bestückungsplan/ Platinenlayout habe ich nicht gefunden).
Platinenversionsnummer (wenn das eine Version angibt und es vielleicht hilft): 62115.40H

Bin für alle Ratschläge offen.
DANKE

Jo0001
Weniger als 15 Beiträge
Weniger als 15 Beiträge
Beiträge: 12
Registriert: 30. Dez 2017 11:58

Re: NXT 2.0 Sensoreingänge defekt

Beitragvon Jo0001 » 13. Jan 2018 12:26

Hallo
besteht das Problem immernoch? Habe nähmlich ein ähnliches: http://www.mindstormsforum.de/viewtopic.php?f=74&t=9094

Jo0001

Tweeky
Mindstormsfreund
Mindstormsfreund
Beiträge: 8
Registriert: 10. Dez 2017 22:20

Re: NXT 2.0 Sensoreingänge defekt

Beitragvon Tweeky » 14. Jan 2018 10:28

Hallo,
ja das Problem habe ich immer noch. Ich habe schon einen neuen Chip eingelötet. Scheinbar hab ich etwas fehlerhaft ausgeführt, da der NXT nicht mehr startet. Ich hatte aber noch keine Zeit weitere Schritte bezüglich Fehlersuche durchzuführen. Wenn ich noch etwas rausfinde, melde ich mich.

Tweeky
Mindstormsfreund
Mindstormsfreund
Beiträge: 8
Registriert: 10. Dez 2017 22:20

Re: NXT 2.0 Sensoreingänge defekt

Beitragvon Tweeky » 27. Jan 2018 10:31

So, jetzt habe icch mir auf der Bay einen neuen, gebrauchten Nxt Stein besorgt. Jetzt kommts, ich habe die gleichen Probleme, wie oben schon beschrieben. Jetzt bin ich ratlos. Liegt es vielleicht doch an den Sensoren? Aber alle gleichzeitig? Kabel? Alle?
Es scheint wenn, dann ein grundsätzliches Problem zu sein. Kennt dies hier keiner? An der verwendeten Spannungsversorgung von AA Akkus sollte es doch nicht liegen, oder? Dann müsste ich mir mal Batterien besorgen. Allerdings drehen die Motoren. Das die Sensoren dann nicht damit klarkommen, entzieht sich meiner Vorstellungskraft.
Bin für alle Vorschläge offen.

Tweeky
Mindstormsfreund
Mindstormsfreund
Beiträge: 8
Registriert: 10. Dez 2017 22:20

Re: NXT 2.0 Sensoreingänge defekt

Beitragvon Tweeky » 27. Jan 2018 11:47

Batterien sind es auch nicht. Keine Verbesserung.

Latz
Schreibt ab und zu
Schreibt ab und zu
Beiträge: 34
Registriert: 26. Jan 2013 18:25

Re: NXT 2.0 Sensoreingänge defekt

Beitragvon Latz » 28. Jan 2018 09:01

Hi,
hast Du die Sensoren mal mit den Testprogrammen auf dem NXT (im Menü "VIEW"/) geprüft?

Latz

Tweeky
Mindstormsfreund
Mindstormsfreund
Beiträge: 8
Registriert: 10. Dez 2017 22:20

Re: NXT 2.0 Sensoreingänge defekt

Beitragvon Tweeky » 28. Jan 2018 19:36

Ja, klar. Mit dem View Programm. Das andere verstehe ich nicht. Ich bin aber ein kleines Stück weiter, glaube ich. Ich habe den Farbsensor angefangen zu messen. Was aufgefallen ist, das mit angeschlossenem Kabel keine 5V zu lesen waren. Den Stecker ausgesteckt könnte ich sie messen. Jetzt bin ich auf der Suche nach einem vollständigen Schaltplan und dem Verursacher. Ich habe die Dioden an der Eingangbeschaltung unter Verdacht.
Hatte hier schon mal jemand diesen Fehler?
Und wenn es das ist, ist das bei allen Sensoren passiert? Wodurch?
Grüße

Tweeky
Mindstormsfreund
Mindstormsfreund
Beiträge: 8
Registriert: 10. Dez 2017 22:20

Re: NXT 2.0 Sensoreingänge defekt

Beitragvon Tweeky » 2. Feb 2018 19:37

Hat jemand wenigstens den Schaltplan zum RGB Sensor? Der im Mindstorms developer kit ist wohl nur der alte NXT Lichtsensor.

tobiwan
Mindstormsfreund
Mindstormsfreund
Beiträge: 5
Registriert: 18. Mär 2018 20:19

Re: NXT 2.0 Sensoreingänge defekt

Beitragvon tobiwan » 20. Mär 2018 05:41

Habe exakt das gleiche Problem: hab ein NXT von einem Kollegen Geschenkt bekommen. Lag mehrere Jahre auf dem Speicher. War sogar noch Originalverpackt. Motor ansteuern geht, aber nur via Dauer, nicht als Winkelangabe. Taster geht. Alle Sensoren gehen nicht und liefern via View und auch mit dem TestMe nur ??? bzw 0 als Wert.

Die Kabel hab ich alle mal durchgetauscht, keine Änderung. An denen liegt es potentiell also nicht. Ich hab meinen Farbsensor jetzt mal zum Testen jemandem gegeben, der ein EV3 hat, die Sensoren sind kompatibel. Mal sehen, was dabei herauskommt.

Gibt es sonst Neuigkeiten?

Jo0001
Weniger als 15 Beiträge
Weniger als 15 Beiträge
Beiträge: 12
Registriert: 30. Dez 2017 11:58

Re: NXT 2.0 Sensoreingänge defekt

Beitragvon Jo0001 » 20. Mär 2018 12:27

Ich hab meinen Farbsensor jetzt mal zum Testen jemandem gegeben, der ein EV3 hat, die Sensoren sind kompatibel. Mal sehen, was dabei herauskommt.

Da bin ich auch gespannt, da ich mir ebenfalls nicht vorstellen kann, dass plötzliche aller Sensoren kaputt sind, nur weil man den NXT ne Weile nicht benutzt hat

tobiwan
Mindstormsfreund
Mindstormsfreund
Beiträge: 5
Registriert: 18. Mär 2018 20:19

Re: NXT 2.0 Sensoreingänge defekt

Beitragvon tobiwan » 21. Mär 2018 11:27

Die Rückmeldung lautet: der Farb-Sensor liefert Daten. Er kann nicht sagen, ob das alles Korrekt läuft, aber die Werte ändern sich passend zu den "gesehenen" Farben. Das ist auch widerholbar. Sprich: die sind gut. Ich bekommen die Tage funktionierende EV3-Sensoren geliehen, um mal andersherum zu testen. Abwarten...

Jo0001
Weniger als 15 Beiträge
Weniger als 15 Beiträge
Beiträge: 12
Registriert: 30. Dez 2017 11:58

Re: NXT 2.0 Sensoreingänge defekt

Beitragvon Jo0001 » 21. Mär 2018 12:23

Das wird ja alles immer verückter.
Ich wusste gar nicht dass die EV3 Sensoren auch NXT geeignet sind.

Tweeky
Mindstormsfreund
Mindstormsfreund
Beiträge: 8
Registriert: 10. Dez 2017 22:20

Re: NXT 2.0 Sensoreingänge defekt

Beitragvon Tweeky » 27. Mär 2018 20:32

Hallo, gibt es schon Neuigkeiten? vom letzten Test? Ich überlege mir mal einen anderen Sensor zu kaufen und es dann damit auszuprobieren. Ich meine die EV3 Sensoren passen nicht zum NXT. Aber wenn doch, wäre das Ergebnis interessant.

Technicmaster0
Schreibt super viel
Schreibt super viel
Beiträge: 381
Registriert: 22. Dez 2010 12:36
Wohnort: In Berlin rechts abbiegen
Kontaktdaten:

Re: NXT 2.0 Sensoreingänge defekt

Beitragvon Technicmaster0 » 28. Mär 2018 11:42

EV3 Sensoren funktionieren nicht ohne weiteres (z.B. den Minsensors EV3 Sensor Multiplexer) mit dem NXT.
Den Schaltplan der Sensoren kann man sich auf https://www.lego.com/en-us/mindstorms/downloads herunterladen: sie sind im EV3- bzw. NXT Hardware Developer Kit.

tobiwan
Mindstormsfreund
Mindstormsfreund
Beiträge: 5
Registriert: 18. Mär 2018 20:19

Re: NXT 2.0 Sensoreingänge defekt

Beitragvon tobiwan » 7. Apr 2018 09:01

Ich kann nur sagen: die EV3 Sensoren liefern auf meinem NXT kein Ergebnis. Allerdings gehen bei meinem NXT die NXT-Sensoren ja auch nicht. Ich schreibe mal Lego direkt an, ob denen dazu was bekannt ist.


Zurück zu „Lego® Mindstorms Hardware“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 8 Gäste

Lego Mindstorms EV3, NXT und RCX Forum : Haftungsauschluss