Seite 1 von 2

NXT 2.0 Sensoreingänge defekt

Verfasst: 13. Dez 2017 12:28
von Tweeky
Hallo erst mal an alle hier!
Ich habe schon ein bisschen gesucht hier im Forum, habe aber auf mein Problem keine wirkliche Antwort gefunden.
Ich, bzw. mein Sohn besitzt ein NXT 2.0 Set. Hat bisher wunderbar funktioniert. Lag dann aber ca. 2 Jahr im Schrank und wurde nicht benutzt. Jetzt wollte der Junior wieder damit anfangen und siehe da die Sensoren, sämtliche (auch die der Motoren) funktionieren nicht mehr. Einzig die relativ dummen Taster tun was sie sollen. Das heißt man kann eigentlich nicht mehr anständig programmieren und das Set nutzen. Die Motoren drehen aber übrigens, allerdings funktioniert die Drehzahlvorgabe nicht.
Jetzt habe ich schon sämtliche Unterlagen gesammelt, den Brick aufgemacht und auch schon angefangen zu messen. Leider habe ich kein Oszi und auch kein Funktionsgenerator. Daher habe ich bisher nur die Spannungsversorgungen durchgemessen. Die funktionieren auch soweit. Die, von mir vermutet defekten Elkos sind alle i.O. Zumindest äusserlich. Einen habe ich zum Test ausgelötet und gemessen. Und wie erwartet war dieser auch i.O.

Kann mir jemand weiterhelfen? Was kann es ausser der Spannungsversorgung noch sein?

Die Sensoren würde ich eigentlich ausschliessen, da alle gleichzeitig defekt sein müssten. Kabel habe ich auch ausgeschlossen (durchgemessen und ausgetauscht).

Evtl. könnte ich in der Firma mit einem Oszi messen, dazu müsste ich aber wissen wo und was genau.
Bei den Unterlagen bin ich mir auch nicht sicher, ob diese passen, da ich einige Messpunkte und Bauteile einfach nicht auf der Platine finden kann (Bestückungsplan/ Platinenlayout habe ich nicht gefunden).
Platinenversionsnummer (wenn das eine Version angibt und es vielleicht hilft): 62115.40H

Bin für alle Ratschläge offen.
DANKE

Re: NXT 2.0 Sensoreingänge defekt

Verfasst: 13. Jan 2018 12:26
von Jo0001
Hallo
besteht das Problem immernoch? Habe nähmlich ein ähnliches: http://www.mindstormsforum.de/viewtopic.php?f=74&t=9094

Jo0001

Re: NXT 2.0 Sensoreingänge defekt

Verfasst: 14. Jan 2018 10:28
von Tweeky
Hallo,
ja das Problem habe ich immer noch. Ich habe schon einen neuen Chip eingelötet. Scheinbar hab ich etwas fehlerhaft ausgeführt, da der NXT nicht mehr startet. Ich hatte aber noch keine Zeit weitere Schritte bezüglich Fehlersuche durchzuführen. Wenn ich noch etwas rausfinde, melde ich mich.

Re: NXT 2.0 Sensoreingänge defekt

Verfasst: 27. Jan 2018 10:31
von Tweeky
So, jetzt habe icch mir auf der Bay einen neuen, gebrauchten Nxt Stein besorgt. Jetzt kommts, ich habe die gleichen Probleme, wie oben schon beschrieben. Jetzt bin ich ratlos. Liegt es vielleicht doch an den Sensoren? Aber alle gleichzeitig? Kabel? Alle?
Es scheint wenn, dann ein grundsätzliches Problem zu sein. Kennt dies hier keiner? An der verwendeten Spannungsversorgung von AA Akkus sollte es doch nicht liegen, oder? Dann müsste ich mir mal Batterien besorgen. Allerdings drehen die Motoren. Das die Sensoren dann nicht damit klarkommen, entzieht sich meiner Vorstellungskraft.
Bin für alle Vorschläge offen.

Re: NXT 2.0 Sensoreingänge defekt

Verfasst: 27. Jan 2018 11:47
von Tweeky
Batterien sind es auch nicht. Keine Verbesserung.

Re: NXT 2.0 Sensoreingänge defekt

Verfasst: 28. Jan 2018 09:01
von Latz
Hi,
hast Du die Sensoren mal mit den Testprogrammen auf dem NXT (im Menü "VIEW"/) geprüft?

Latz

Re: NXT 2.0 Sensoreingänge defekt

Verfasst: 28. Jan 2018 19:36
von Tweeky
Ja, klar. Mit dem View Programm. Das andere verstehe ich nicht. Ich bin aber ein kleines Stück weiter, glaube ich. Ich habe den Farbsensor angefangen zu messen. Was aufgefallen ist, das mit angeschlossenem Kabel keine 5V zu lesen waren. Den Stecker ausgesteckt könnte ich sie messen. Jetzt bin ich auf der Suche nach einem vollständigen Schaltplan und dem Verursacher. Ich habe die Dioden an der Eingangbeschaltung unter Verdacht.
Hatte hier schon mal jemand diesen Fehler?
Und wenn es das ist, ist das bei allen Sensoren passiert? Wodurch?
Grüße

Re: NXT 2.0 Sensoreingänge defekt

Verfasst: 2. Feb 2018 19:37
von Tweeky
Hat jemand wenigstens den Schaltplan zum RGB Sensor? Der im Mindstorms developer kit ist wohl nur der alte NXT Lichtsensor.

Re: NXT 2.0 Sensoreingänge defekt

Verfasst: 20. Mär 2018 05:41
von tobiwan
Habe exakt das gleiche Problem: hab ein NXT von einem Kollegen Geschenkt bekommen. Lag mehrere Jahre auf dem Speicher. War sogar noch Originalverpackt. Motor ansteuern geht, aber nur via Dauer, nicht als Winkelangabe. Taster geht. Alle Sensoren gehen nicht und liefern via View und auch mit dem TestMe nur ??? bzw 0 als Wert.

Die Kabel hab ich alle mal durchgetauscht, keine Änderung. An denen liegt es potentiell also nicht. Ich hab meinen Farbsensor jetzt mal zum Testen jemandem gegeben, der ein EV3 hat, die Sensoren sind kompatibel. Mal sehen, was dabei herauskommt.

Gibt es sonst Neuigkeiten?

Re: NXT 2.0 Sensoreingänge defekt

Verfasst: 20. Mär 2018 12:27
von Jo0001
Ich hab meinen Farbsensor jetzt mal zum Testen jemandem gegeben, der ein EV3 hat, die Sensoren sind kompatibel. Mal sehen, was dabei herauskommt.

Da bin ich auch gespannt, da ich mir ebenfalls nicht vorstellen kann, dass plötzliche aller Sensoren kaputt sind, nur weil man den NXT ne Weile nicht benutzt hat

Re: NXT 2.0 Sensoreingänge defekt

Verfasst: 21. Mär 2018 11:27
von tobiwan
Die Rückmeldung lautet: der Farb-Sensor liefert Daten. Er kann nicht sagen, ob das alles Korrekt läuft, aber die Werte ändern sich passend zu den "gesehenen" Farben. Das ist auch widerholbar. Sprich: die sind gut. Ich bekommen die Tage funktionierende EV3-Sensoren geliehen, um mal andersherum zu testen. Abwarten...

Re: NXT 2.0 Sensoreingänge defekt

Verfasst: 21. Mär 2018 12:23
von Jo0001
Das wird ja alles immer verückter.
Ich wusste gar nicht dass die EV3 Sensoren auch NXT geeignet sind.

Re: NXT 2.0 Sensoreingänge defekt

Verfasst: 27. Mär 2018 20:32
von Tweeky
Hallo, gibt es schon Neuigkeiten? vom letzten Test? Ich überlege mir mal einen anderen Sensor zu kaufen und es dann damit auszuprobieren. Ich meine die EV3 Sensoren passen nicht zum NXT. Aber wenn doch, wäre das Ergebnis interessant.

Re: NXT 2.0 Sensoreingänge defekt

Verfasst: 28. Mär 2018 11:42
von Technicmaster0
EV3 Sensoren funktionieren nicht ohne weiteres (z.B. den Minsensors EV3 Sensor Multiplexer) mit dem NXT.
Den Schaltplan der Sensoren kann man sich auf https://www.lego.com/en-us/mindstorms/downloads herunterladen: sie sind im EV3- bzw. NXT Hardware Developer Kit.

Re: NXT 2.0 Sensoreingänge defekt

Verfasst: 7. Apr 2018 09:01
von tobiwan
Ich kann nur sagen: die EV3 Sensoren liefern auf meinem NXT kein Ergebnis. Allerdings gehen bei meinem NXT die NXT-Sensoren ja auch nicht. Ich schreibe mal Lego direkt an, ob denen dazu was bekannt ist.